PHP v5.2 Deprecation on our Linux Servers

Last month we announced that our servers now support PHP 5.4. Now our Linux Hosting Servers support PHPv5.4!

We are now discontinuing the support for the older PHP versions on our servers (PHP v5.2). This deprecation of PHP v5.2 will happen from the 17th of March. Users can choose to move to PHP v5.4 or PHP v5.3 as preferred. The default will be PHP v5.4 March 17th onwards. We will still continue providing support for PHP v5.3.

Action Required: You should ideally not face any negative impact due to this impending switch as PHP v5.3 and PHP v5.4 are both backward compatible. However, we strongly recommend that you follow the steps mentioned steps mentioned here to switch versions before the 17th of March, 2014 to verify that there is indeed no disruption. This will ensure that you have adequate time to make the necessary code changes at your end, if any, before the automatic upgrade goes live.

Numerous vulnerabilities in PHP v5.2 have been addressed in its succeeding versions and this upgrade is strongly recommended by industry experts. The latest enhancements significantly improve PHP’s elegance, resulting in a dramatic optimization of the runtime (up to 20% more speed and memory usage reduction).